Log in

I forgot my password

Latest topics

» "Poison Ivy"
Fri Oct 30, 2015 9:31 pm by AJracer33a

» Project Onyx
Wed Oct 21, 2015 8:46 pm by Onyx

» Hey Guys
Wed Oct 21, 2015 8:25 pm by Onyx

» WOT Tuning Basics
Mon Oct 19, 2015 12:08 pm by AJracer33a

» new to the forum/me member on fb
Sat Oct 10, 2015 12:52 pm by AJracer33a

» DSM beginner
Sat Oct 10, 2015 12:51 pm by AJracer33a

» 4G37 Timing Belt Install Gone Wrong
Fri Feb 13, 2015 2:02 am by SafetyAl

»  '93 7 Bolt 4G63T
Sat Jan 31, 2015 9:04 pm by crazyccustoms666

» My DSM History
Wed Jan 28, 2015 10:25 pm by pointblank9957

Who is online?

In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None


[ View the whole list ]


Most users ever online was 31 on Mon Feb 27, 2012 6:49 pm


    95 Talon TSi

    Share
    avatar
    AJracer33a
    Admin
    Admin

    Car : 95 Talon TSi AWD
    Posts : 684
    Reputation : 12
    Join date : 2012-01-18
    Location : Athens, PA
    20120319

    2G 95 Talon TSi

    Post by AJracer33a

    So guys, I got my new DSM. 95 Talon TSi with a 97 TSi body. Her name is Faline and yes, she needs paint. But the body is great, interior is amazing, engine bay is clean, and all for $2000. I will list the long list of mods when I can but here are some pics until then.

    Speedometer/odometer didn't work when I bought it. That's fixed. Bucked hard when I got it, that is pretty well fixed and she pulls hard. Fixed some boost leaks, deleted emmisions, and some other random stuff. This is going to be a very fun car and fun learning process as it is my first 2G.

    Hope you guys like.



    Kurt and I




    After emmisions delete.


    Last edited by AJracer33a on Thu Jan 03, 2013 11:42 pm; edited 2 times in total


    ________________________________________________
    Share this post on: Excite BookmarksDiggRedditDel.icio.usGoogleLiveSlashdotNetscapeTechnoratiStumbleUponNewsvineFurlYahooSmarking

    Post on Mon Mar 19, 2012 4:32 pm by Guest

    Well get her done right. Just from the emissions and bcs delete it made a huge difference.
    avatar

    Post on Mon Mar 19, 2012 6:07 pm by 92tsifwd

    I like that car man alot! Glad I could help haha. We are gonna have some FWD monsters!
    avatar

    Post on Wed Mar 21, 2012 12:31 am by Shake_Zulla

    I don't think it needs paint, it looks better than mine! Lets call her Skittles cause shes all the colors of the rainbow.
    avatar

    Post on Tue Mar 27, 2012 10:18 am by AJracer33a

    Spun a bearing Wednesday, swapped in the rebuilt 7 bolt, drove her home Friday. Pics!!!











    avatar

    Post on Tue Mar 27, 2012 7:29 pm by 92tsifwd

    Thats awesome that happened in the parking lot lol. Whats the chances?!
    avatar

    Post on Tue Mar 27, 2012 9:36 pm by AJracer33a

    So yea, I spun a rod bearing on cylinder 3. The motor I built for the 1g is now in this thing.

    Named the car Feline. Feline is Bambi's gfs name in the disney movie. The car bucked when I bought it hense naming it after a deer. Although I did like Skittles, Shake.

    Mods are: tubular headers, 1g cas, walbro 255 fuel pump, fmic and hard piping, front upper strut bar, and k & n air filter.

    I have replaced some brake lines and a few other odds and ends.

    She runs great and pulls harder since the motor swap. I need to get NGK plugs and wires next. Only have a few more maintenance projects left. Ive done more to this car in a week than most do witn a car for a whole year. Not by choice either lol.

    Gunna be dropping in my 1g radiator tomorrow which requires a little modification.
    avatar

    Post on Tue Mar 27, 2012 9:36 pm by AJracer33a

    So yea, I spun a rod bearing on cylinder 3. The motor I built for the 1g is now in this thing.

    Named the car Feline. Feline is Bambi's gfs name in the disney movie. The car bucked when I bought it hense naming it after a deer. Although I did like Skittles, Shake.

    Mods are: tubular headers, 1g cas, walbro 255 fuel pump, fmic and hard piping, front upper strut bar, and k & n air filter.

    I have replaced some brake lines and a few other odds and ends.

    She runs great and pulls harder since the motor swap. I need to get NGK plugs and wires next. Only have a few more maintenance projects left. Ive done more to this car in a week than most do witn a car for a whole year. Not by choice either lol.

    Gunna be dropping in my 1g radiator tomorrow which requires a little modification.

    Post on Wed Mar 28, 2012 12:30 pm by Guest

    told you wed get it running right
    avatar

    Post on Wed Mar 28, 2012 5:04 pm by AJracer33a

    3/28/12

    Swapped in the 1g radiator. Very easy to do. All you need to do is cut off the pegs on the bottom of the 1g radiator. It dropped right in. You need to use the 1g upper radiator hose with the 2g lower hose. You do have to cut the 1g upper radiator hose to make it a little shorter. There is quite a bit more room in the exhaust manifold/turbo area though since the outlet for the upper hose on a 1g radiator is on the passenger side where as the 2g outlet is smack dab in the middle of the radiator.
    avatar

    Post on Wed Apr 04, 2012 9:15 am by AJracer33a

    4/5/12

    Crazy weekend. Friday, I relocated tbe fuse box lower underneath the intake pipe/MAF and against the frame. That cleaned things up a bit.

    Saturday, I headed up north to get my daughter. After I got her, I met Kurt with his 1G and he followed me to the town Ryan (with the Evo) lives in. On the way there, we had some complications with Kurts car. Then, mine.

    The Talon shut off. At this time, I didn't know why but it would not run. Turned out to be the shitty power transistor plug that popped off.

    I have done the Potentiometer (volume control knob) Mod to the Talon. With the 1G CAS on the 2G, it is very common to have a random misfire while cruising. The Pot Mod, fixes this. It's more of a band aid.

    I wired up the Pot to the wire for the barometric pressure sensor wire that goes to the ECU. You turn the knob on the Pot up and it changes the resistance going to the ECU so the ECU thinks you are on Mount Everest (high elevation) and in turn the ECU will no longer make the engine misfire. For more info and how to do this, CLICK THIS LINK

    I also have an issue that I need to address soon. While the base ignition timing is set at 5* BTDC where it is supposed to be, the car runs like ass. The thing barely moves. But if I advance the CAS all the way, she runs absolutely amazing. This is not a good idea because you can easily melt your pistons.

    I am not sure why this is happening quite yet, but it's obvious something is telling the ECU to pull timing like crazy when the base timing is 5* BTDC. Could be reading knock at 5* and no knock when fully advanced, could be boost leaks, could be a lot of things. I had to run my 1G like this as well.

    Also, I have failed to mention that I have the 1G DSM AWD big brake swap.

    Well, that should get you up to speed. I am not really sure what is coming up next but I may be painting her soon! Going white and black since I have always wanted a Panda! My girl friend is actually going to be doing all the body work and paint. She has a lot more experience with this stuff than I do.

    Well, till next time. See ya!













    avatar

    Post on Thu Apr 05, 2012 7:08 pm by 92tsifwd

    That was a very eventful weekend I must say so myself lol. Glad you got it figured out though.

    Post on Thu Apr 05, 2012 9:18 pm by Guest

    92tsifwd wrote:That was a very eventful weekend I must say so myself lol. Glad you got it figured out though.

    *glad he has a friend like chris who knows his stuff when it comes to 2g's
    avatar

    Post on Fri Apr 06, 2012 8:30 pm by 92tsifwd

    lol that too. Im a 1g guy. I do want a 2g tho.
    avatar

    Post on Thu Apr 12, 2012 11:49 am by AJracer33a

    4/12/12

    I installed an unknown brand of lowering springs yesterday! They are red and have no name on them. Hopefully I can eventually find out what they are. But, they dropped my ride height 1 1/2" and I am quite satisfied with them.

    Next, I have to fix my BISS screw and BOV.

    Here are some more pics!



    avatar

    Post on Mon Apr 16, 2012 9:59 am by AJracer33a

    4-16-12

    Yesterday, I decided to finally night shade my tail lights. First attempt sucked. The nozzle for the spray can was shot so it spit all over. Used brake cleaner to remove all the night shade and started again with a new nozzle.

    The second time around was much better, but not what I was hoping for. It was an old can of night shade. Still have some tidying up to do on them but they will do for now.

    Next, my girl friend was in the mood for some body work. So she decided to paint my hood. She sanded the hood down to remove the clear coat. Eventually when she was all prepped, she began paint. We just rattle canned it because we are planning on painting the whole car soon.

    For rattle can paint, it turned out pretty good. Still have to wetsand it yet.

    I ordered a new BISS screw and BOV gasket from Extreme PSI Friday. They should arrive today. Wednesday, I am going over to the garage so I can put them on.

    PICS!





















    avatar

    Post on Mon Apr 16, 2012 5:12 pm by 92tsifwd

    Looks awesome bro!
    avatar

    Post on Tue Apr 17, 2012 12:37 pm by AJracer33a

    Thanks man. Shes coming along.
    avatar

    Post on Tue May 01, 2012 3:36 pm by AJracer33a

    Coming soon...

    ARP Head Studs
    Headgasket
    Intake Manifold Gasket
    EVO III 16G Turbo
    3.0" Exhaust
    avatar

    Post on Mon May 28, 2012 4:13 am by AJracer33a

    Haven't really touched the TSi in awhile. I've been helping Chris on his beastly build. I do plan to paint my 2Gb Eclipse wheels that I had on my 1g, black and put them on the 2G. I photoshopped this pic.



    And here is a normal pic.

    avatar

    Post on Fri Jun 01, 2012 7:56 pm by AJracer33a

    6-1-12

    Painted the wheels a couple days ago. Just put them on yesterday. I must say, with these wheels, it looks like a whole new car. So much nicer looking.

    Heres the pics!



    avatar

    Post on Fri Jun 01, 2012 8:36 pm by 92tsifwd

    Love it man! We need to get more pics!
    avatar

    Post on Fri Jun 01, 2012 10:58 pm by AJracer33a

    Yea we do. I am so happy with how these wheels turned out.
    avatar

    Post on Sun Jun 03, 2012 11:50 pm by 92tsifwd

    Ya they are pretty sick! I been thinking about getting some coil overs and lowering springs and some camber plates for my rear wheels. Or Im gonna get the coil overs and springs and get some smaller rims and get 1.5 inch wheel spacers to widen my stance a little bit.
    avatar

    Post on Mon Jun 04, 2012 11:20 am by AJracer33a

    Yea, either way to go, I will look sexy as hell. I wouldn't mind trying out some wheel spacers myself.
    avatar

    Post on Mon Jun 04, 2012 6:31 pm by 92tsifwd

    They will look sick
    avatar

    Post on Mon Jun 04, 2012 9:27 pm by AJracer33a

    6-4-12

    Friday, I heard something fall off my car while driving. Sounded like a bolt or wrench as it had that "pinging" noise when making contact with the road surface.

    Saturday, I went to tighten up my alternator belt because the squealing had escalated. Well, I took the tensioner off, and when I did, the alternator about fell off the car.

    I quickly realized the alternator pivot bolt is what fell off of my car the night before. So, I hitched a ride to Napa and got a couple new bolts and nuts to use as the pivot bolt. I ended up with:

    M8 x 1.25mm pitch Bolt and Nut- 118mm in length.

    No more squealing.

    Today on the way back from my drug screening for work (yes, I passed), I noticed my heater blowing cold air. So I immediately looked at the temperature gauge. Yep, she was getting hot.

    So I pulled over. The rubber hose running to the oil filter housing had a splice in it. I noticed the hose becoming weak while I fixed the alternator so this was no surprise to me.

    Got the aluminum racing jack out, put my overalls on, and grabbed a new hose out of my hatch. Cut the hose to the correct length, put it on, problem solved.

    Meanwhile, here are some pics from over the weekend when I had my beautiful daughter.



    avatar

    Post on Tue Jun 05, 2012 8:02 pm by 92tsifwd

    Shes gorgous man! I had the same problem with the hose to my oil filter housing, leaked coolant everywhere.
    avatar

    Post on Wed Jun 06, 2012 5:11 pm by AJracer33a

    Thanks man.

    Yea it was leaking all over the damn place. But, I repaired it along side the road lol.
    avatar

    Post on Mon Jun 18, 2012 7:52 pm by AJracer33a

    6-18-12

    Yesterday after I watched Dale Jr. get his first win in exactly 4 years, I felt ambitious so I did a couple things.

    I lowered the battery onto the subframe, removed the cruise control actuator (other CC gadgets are still there), removed the sound deadening on the firewall, relocated some things on the firewall, and removed the horn for the factory alarm that was on the firewall.

    I need to do some thorough cleaning once I get some Purple Power. Also going to tape up the wiring harness which is now exposed, and paint my VC.

    Here are some pics.

    Before





    After





    avatar

    Post on Thu Jun 21, 2012 8:57 pm by AJracer33a

    6-21-12

    Just bought a 14B in good condition. It comes with the J-pipe, oil feed line, oil lines, oil return pipe, hotside, wastegate, water lines, etc.

    So, when it arrives, off comes the POS T-2small!

    I am also in the midst of sanding/painting another valve cover. It's going to be purple with silver letters. Should look alright.
    avatar

    Post on Sat Jun 23, 2012 2:20 pm by 93blackeclipse

    Great build man! looks good. i like what you did with the taillights. You have cleaned that bay up pretty good.cheers
    avatar

    Post on Sat Jun 23, 2012 3:45 pm by AJracer33a

    Painting the bay right now. Ill post pics asap.
    avatar

    Post on Sat Jun 23, 2012 4:22 pm by 93blackeclipse

    Looking foward to seeing it!
    avatar

    Post on Sat Jun 23, 2012 4:26 pm by AJracer33a

    I will try and get the valve cover painted today too. I am dealing with a 3-4 week old kitten that is dieing. Trying to feed her so she can pull through.
    avatar

    Post on Sat Jun 23, 2012 6:47 pm by 93blackeclipse

    Oh really, Sorry to hear that man.
    avatar

    Post on Sun Jun 24, 2012 1:12 pm by AJracer33a

    The kitten passed away last night. I feel bad, but we dd the best we could...

    She is finished. Painted the entire engine bay and also painted the VC. Pics below.











    Here is a before and after pic. The before pic was from the day I bought the car back in March.

    avatar

    Post on Sun Jun 24, 2012 2:46 pm by 93blackeclipse

    Wow! What a big differance. You did a great a job. Whats next on your plan list?
    avatar

    Post on Sun Jun 24, 2012 3:17 pm by AJracer33a

    Just painted the underside of the hood white since it was red.

    I am going to throw some stickers on it that I have been saving up for when I painted the hood.

    I like the look of a "sticker bombed" underside hood.

    Next, next big plans, is the 14B when it comes in the mail. Should be here Thursday. So I will install it Thursday night or Friday.
    avatar

    Post on Sun Jun 24, 2012 3:25 pm by 93blackeclipse

    Nice. Ya I also like the stickers under the hood. Cant wait to see the turbo install should be good!
    avatar

    Post on Sun Jun 24, 2012 3:28 pm by AJracer33a

    Yep. I will make a tech article about how to install a 14B on a 2G.

    I cannot believe this lil T-25 is still holding up. The shaft play is crazyy.
    avatar

    Post on Sun Jun 24, 2012 3:46 pm by 93blackeclipse

    Good deal iam sure alot of ppl will find it helpful. Ya iam sure any car thats turboed and 17 years old would shaft play. Just more of a reason to upgrade.cheers
    avatar

    Post on Sun Jun 24, 2012 5:13 pm by AJracer33a

    Painted the hood, and sticker bombed it!













    avatar

    Post on Sun Jun 24, 2012 5:14 pm by AJracer33a

    93blackeclipse wrote:Good deal iam sure alot of ppl will find it helpful. Ya iam sure any car thats turboed and 17 years old would shaft play. Just more of a reason to upgrade.cheers

    Yea, more or less gives me an excuse to upgrade sooner lol.
    avatar

    Post on Sun Jun 24, 2012 6:57 pm by 93blackeclipse

    Thats the only place i like putting stickers. looks good.
    avatar

    Post on Sun Jun 24, 2012 8:43 pm by AJracer33a

    Thanks man. Busted my ass all weekend lol.
    avatar

    Post on Mon Jun 25, 2012 9:59 pm by AJracer33a

    More pics with Ryan's Evo (Misty).



















    avatar

    Post on Mon Jun 25, 2012 10:03 pm by 93blackeclipse

    Nice cant wait to see them. I seen the one, But the more the merrier.Very Happy
    avatar

    Post on Tue Jun 26, 2012 1:33 am by 92tsifwd

    After we get my car going we need another meet! I can ask the owners of the church across the street for me if it would be ok to use their huge parking lot for a little bit.
    avatar

    Post on Tue Jun 26, 2012 5:34 pm by AJracer33a

    Sounds like a plan, Kurt.

    Post  by Sponsored content


      Current date/time is Wed Sep 20, 2017 7:05 am