Log in

I forgot my password

Latest topics

» "Poison Ivy"
Fri Oct 30, 2015 9:31 pm by AJracer33a

» Project Onyx
Wed Oct 21, 2015 8:46 pm by Onyx

» Hey Guys
Wed Oct 21, 2015 8:25 pm by Onyx

» WOT Tuning Basics
Mon Oct 19, 2015 12:08 pm by AJracer33a

» new to the forum/me member on fb
Sat Oct 10, 2015 12:52 pm by AJracer33a

» DSM beginner
Sat Oct 10, 2015 12:51 pm by AJracer33a

» 4G37 Timing Belt Install Gone Wrong
Fri Feb 13, 2015 2:02 am by SafetyAl

»  '93 7 Bolt 4G63T
Sat Jan 31, 2015 9:04 pm by crazyccustoms666

» My DSM History
Wed Jan 28, 2015 10:25 pm by pointblank9957

Who is online?

In total there are 2 users online :: 0 Registered, 0 Hidden and 2 Guests

None


[ View the whole list ]


Most users ever online was 31 on Mon Feb 27, 2012 6:49 pm


    95 Talon TSi

    Share
    avatar
    AJracer33a
    Admin
    Admin

    Car : 95 Talon TSi AWD
    Posts : 684
    Reputation : 12
    Join date : 2012-01-18
    Location : Athens, PA
    20120319

    2G 95 Talon TSi

    Post by AJracer33a

    So guys, I got my new DSM. 95 Talon TSi with a 97 TSi body. Her name is Faline and yes, she needs paint. But the body is great, interior is amazing, engine bay is clean, and all for $2000. I will list the long list of mods when I can but here are some pics until then.

    Speedometer/odometer didn't work when I bought it. That's fixed. Bucked hard when I got it, that is pretty well fixed and she pulls hard. Fixed some boost leaks, deleted emmisions, and some other random stuff. This is going to be a very fun car and fun learning process as it is my first 2G.

    Hope you guys like.



    Kurt and I




    After emmisions delete.


    Last edited by AJracer33a on Thu Jan 03, 2013 11:42 pm; edited 2 times in total


    ________________________________________________
    Share this post on: Excite BookmarksDiggRedditDel.icio.usGoogleLiveSlashdotNetscapeTechnoratiStumbleUponNewsvineFurlYahooSmarking

    avatar

    Post on Wed Jun 27, 2012 10:07 pm by AJracer33a

    6-26-12 <--My bday

    Retapped 3 of my VC bolt holes that were stripped.

    I used the preferred 1/4"-20 bolts that are 1" in length.

    No more leaks!

    Eventually, I want to helicoil all of the VC bolt holes.

    The 14B SHOULD be here tomorrow.
    avatar

    Post on Wed Jun 27, 2012 11:38 pm by 93blackeclipse

    Nice good to hear, Damn leaks. Happy Birthday man!
    avatar

    Post on Fri Jun 29, 2012 4:27 pm by 92tsifwd

    Damn bro I missed your BDay.... Well happy late Birthday Man!
    avatar

    Post on Fri Jun 29, 2012 5:31 pm by AJracer33a

    The 14B came yesterday. Without the gosh damn J- Pipe. Not to mention the oil hard line was bent thus putting a big kink in it.

    Oh, my car is SUPER loud now. Thanks to the tubular header cracking (I think it is because of the header cracked anyway). Sounds like one helluva open o2 dump.

    Hopefully I can get this taken care of.

    Can't swap the turbo until I get a J- Pipe and figure out something with that oil line.
    avatar

    Post on Sat Jun 30, 2012 6:41 pm by 92tsifwd

    Try bending the oil line back. Im pretty sure u can just buy one seperate I seen one on CL earlier today.
    avatar

    Post on Sun Jul 01, 2012 6:11 pm by AJracer33a

    4-1-12

    Ok, quite a few things happened. Turns out that exhaust leak that I thought was coming from my tubular header, was actually my exhaust pipe where the downpipe goes to the flex pipe.

    Friday while driving home, I noticed the car getting a little louder. Got home, popped the hood. I looked at the manifold with the car on. It seemed to me that the crack in the header may not be where the leak was. Or at least, the big leak.

    It sounded lower. I have like 3" of clearance under the front bumper and didn't feel like jacking up the car.

    So, went out and got cigs. Then, bam. Car was extremely loud, and heard a weird noise. A mile or so later I got home. Jacked it up and found this (not a surprise after the last trip of driving, looked for this right away).



    So yea, as you can see, open header now. The previous owner redid the exhaust on this car using the same diameter exhaust as the stock exhaust, and literally could not weld.

    All of the welds on the exhaust are TERRIBLE. You can see several strands of wire stuck in the beads. Finally, one of the crappy welds broke. This is where the leak came from when I thought it was the header. Started out like a quiet exhaust leak until this.

    Went to my gramps and cut a section of the exhaust off and hung the rest of it with some wire for now.

    I am glad this happened though. My oil filter was loose and was about to fall off. Noticed it when cutting the exhaust off. That was a close one.









    So, she is open header right now.
    avatar

    Post on Sun Jul 01, 2012 6:21 pm by 93blackeclipse

    Wow i like that camaro. Atleast it wasnt the header. What are you planing on running for exhaust than? Just a down pipe?
    avatar

    Post on Sun Jul 01, 2012 6:43 pm by AJracer33a

    Open header for now. There is a piece of downpipe on it still. Eventually I will have to buy a new exhaust. So I am going to try and DD the car till I do because I have no choice if I wanna get to work.

    It sounds amazing!
    avatar

    Post on Mon Jul 02, 2012 11:30 am by 93blackeclipse

    Haha. I bet it sounds good. Are you going to go with a cat-back system? Or just go to a regular exhaust shop?
    avatar

    Post on Mon Jul 02, 2012 12:06 pm by AJracer33a

    I am going to look for a 3" downpipe, high flow cat/test pipe, then get a 3" cat back. I might just make my own. Thats what i will most likely do. I might find an aftermarket muffler too (not a fart can).
    avatar

    Post on Mon Jul 02, 2012 8:24 pm by 93blackeclipse

    That Should sound nice. You better post a sound clip when its done! cheers
    avatar

    Post on Mon Jul 02, 2012 9:41 pm by AJracer33a

    Why wait? Here are vids from what it sounds like now. Sound better on my iphone.

    First gear pull.
    http://illiweb.com/fa/pbucket.gif4

    Idle, rev.
    http://illiweb.com/fa/pbucket.gif4

    3rd gear pull/cruise.
    http://illiweb.com/fa/pbucket.gif4

    Heres a higher quality video of another DSM with side exit. Mine sounds EXACTLY the same minus the lopey idle.

    http://illiweb.com/fa/pbucket.gif4
    avatar

    Post on Mon Jul 02, 2012 11:19 pm by 93blackeclipse

    I like the way it sounds. What brand header are you running?
    avatar

    Post on Tue Jul 03, 2012 10:05 pm by 92tsifwd

    Be careful with them open headers man! Cops and bent valves are a huge problem with oven headers.
    avatar

    Post on Tue Jul 03, 2012 10:16 pm by AJracer33a

    93blackeclipse wrote:I like the way it sounds. What brand header are you running?

    Ebay tubular header :/
    avatar

    Post on Sun Jul 08, 2012 12:04 am by 93blackeclipse

    Icic. Have you ever thought of getting a FP manifold?
    avatar

    Post on Sun Jul 08, 2012 1:49 pm by AJracer33a

    93blackeclipse wrote:Icic. Have you ever thought of getting a FP manifold?

    That's my favorite manifold. There was actually a sale on them recently on one of the DSM vendor sites. Im not sure if it's over yet.

    Wednesday, I went down to my girl friends where I just moved from (2 and a half hours from where I live now). Right before I pulled into the driveway, I did a launch. My oil filter came loose and I lost EVERY last drop of oil.

    Thursday morning, the local parts store delivered oil and a filter to me. Then told me to come up to the store when I was done and pay them. So, took the old filter off and sure enough the shaft that the filter threads onto was loose. Not a surprise as this is normally the reason a filter comes loose. So I tightened it up.





    Put everything together, added oil, and put about 70 miles on the car. Came back to my girl friends and there was very little oil on my dipstick. Filter was still tight but there was a leak between the ofh and oil cooler.





    See that little orange thing sticking out? This is the seal/o ring that is on the back side of the ofh.

    So I took the ofh off.



    In the picture below, the orange seal is that seal that I am talking about.



    Clearly, it is torn and this is where the leak was coming from. The seal is a dealer item so it could not be bought from a parts store. I ended up re-using the seal and siliconed the shit out of it. The leak was fixed.

    Pain in the ass, but she doesn't lose any oil anymore.
    avatar

    Post on Sun Jul 08, 2012 2:20 pm by 93blackeclipse

    Wow! Your lucky you caught that. Glad you found the other leak thought. Could have caused a major problem.
    avatar

    Post on Sun Jul 08, 2012 5:03 pm by AJracer33a

    Yea. It wasn't hard to tell I lost 4.5 quarts of oil at once (left front wheel locked up when braking). But, if I didnt notice this, motor would have been toast. Oil psi obviously dropped, I noticed that first.
    avatar

    Post on Sun Jul 08, 2012 6:10 pm by 92tsifwd

    Glad you cought it bro. Should go ahead and order that seal though because that silicone probably wont hold forever. Plus its better to get it done right anyways. My brothers Talon had a crack in the block and all his oil spilled out and his motor seized. Thats why he got a new motor.
    avatar

    Post on Sun Jul 08, 2012 6:45 pm by AJracer33a

    I am trying to find that seal at a vendor or online anywhere for that matter. Don't have any dealerships around here. But yes, I need to get it.
    avatar

    Post on Sun Jul 08, 2012 8:54 pm by 93blackeclipse

    Yah i hope you can find that seal. silicones good for temperary fixes, but i never trust it for too long.
    avatar

    Post on Mon Jul 09, 2012 2:01 am by 92tsifwd

    A Chrysler or Mitsu dealer can get it. Ill check at Tunk Auto Mart next time Im downtown. Im going to a junkyard tomorro so Ill check there too.
    avatar

    Post on Mon Jul 09, 2012 4:07 pm by 93blackeclipse

    Would any of the auto parts stores carry the right size seal? Just a suggestion.
    avatar

    Post on Mon Jul 09, 2012 6:30 pm by AJracer33a

    I am sure there is a seal that a parts store carries that would work. But it would take a while to find it.

    I think I am just going to get a used one. Anybody with a ofh will have one.

    Hell, I wanna upgrade to the 90 forward facing ofh anyway. Maybe I will just buy one.
    avatar

    Post on Mon Jul 09, 2012 9:56 pm by 93blackeclipse

    Yah the 90 degree one would be nice. Shouldnt be to bad of a price either.
    avatar

    Post on Tue Jul 10, 2012 5:20 pm by AJracer33a

    Nevermind, the 1990 ofh will NOT bolt up to a 7 bolt. Forgot the bolt patterns are completely different.

    So, guess I need either an Evo 3 ofh or Evo 8/9 ofh.

    UPDATE: Today on the way to work, my oil feed line for the turbo sliced open somehow and leaked. So, AGAIN, all my oil was drained out. AGAIN, caught it before I toasted my engine.

    Pulled over as soon as I noticed the oil pressure drop and shut her down. My oil feed line runs from the ofh to the turbo and is just basically a brake line.

    So I took the old line off, walked to a "hole in the wall garage", got a new hard line, oil, put it back together and went to work- 3 hours late.
    avatar

    Post on Tue Jul 10, 2012 10:55 pm by 93blackeclipse

    Wow you have trouble keeping oil in her! Good thing you catch it everytime.
    avatar

    Post on Wed Jul 11, 2012 3:50 pm by 92tsifwd

    Damn dude you have my luck with DSM's lol. Good thing you caught it again.
    avatar

    Post on Sat Jul 14, 2012 1:09 am by AJracer33a

    Went to the drag strip tonight for Test & Tune.

    My daughter had an amazing time, my best friend Ryan had a good time, car didn't break or leak anything, was awesome. Think my Potentiometer (for the 10k Pot Mod) took a shit. Started misfiring yesterday just like it did before i did the Pot Mod. Timing was being pulled all night, and i am boosting 3-5psi less than what i normally do. 10.391 was my best time in the 1/8, .5610 was the best reaction time, 2.2701 was my best 60ft, best mph was 69.13. There was a 3000gt that ran 10.3 as well, another 3000gt running low 11's, and a colbalt ss running somewhere in the 11's.

    avatar

    Post on Sun Jul 15, 2012 9:28 pm by 93blackeclipse

    Nice!! Now time to beat it! Haha!
    avatar

    Post on Tue Jul 17, 2012 5:46 pm by AJracer33a

    Many many updates. Put the 14B on finally, had to get some parts to do it but it is done.

    I have a problem that is most likely timing being pulled due to a bad knock sensor. So, once I get a new sensor, hopefully that is fixed. I am only boosting 5psi still. It won't go past that. I don't build any boost at all until 4000RPM. She really starts to take off after 5000RPM.

    We will get er done. Hopefully in time for test and tune friday.
    avatar

    Post on Tue Jul 17, 2012 10:29 pm by 93blackeclipse

    Good to hear you got the 14b on finally can't wait to see the times when its running good!
    avatar

    Post on Tue Jul 17, 2012 10:31 pm by dkalfop

    Wow! You are a busy beaver! This my first time on this site. I really like the layout, but still unsure about some things. How do I start a thread similar to this one to tell my story? I want to up load pics but can't really find a way. I have already uploaded to photobucket, but can't insert my car's pic on my profile.
    avatar

    Post on Tue Jul 17, 2012 10:38 pm by 93blackeclipse

    Welcome to the site! You just have to go to project logs and start new thread. Make sure you make an introduction. About the pictures just go to your photobucket and put your arrow on the picture and click on img code and it will automatically copy it. Than just paste in the reply of you project log.
    avatar

    Post on Thu Jul 19, 2012 1:53 am by 92tsifwd

    Hows that 14b pullin'?
    avatar

    Post on Fri Jul 20, 2012 12:50 am by AJracer33a

    dkalfop wrote:Wow! You are a busy beaver! This my first time on this site. I really like the layout, but still unsure about some things. How do I start a thread similar to this one to tell my story? I want to up load pics but can't really find a way. I have already uploaded to photobucket, but can't insert my car's pic on my profile.

    Thank you, man. And welcome to the site. As "93blackeclipse" said, it is easy. Go to the Project Log forum, and click "New Thread".

    I posted in the other thread you replied to. If you haven't seen it, check it out. I posted a link to a FAQ about pictures.

    93blackeclipse wrote:Welcome to the site! You just have to go to project logs and start new thread. Make sure you make an introduction. About the pictures just go to your photobucket and put your arrow on the picture and click on img code and it will automatically copy it. Than just paste in the reply of you project log.

    Thanks for helping him out.

    92tsifwd wrote:Hows that 14b pullin'?

    Umm....20PSI...pulls like a son of a bitch. Like, harder than Ryan's Evo. Needless to say, I hit fuel cut and can only go 1/4 throttle. The car is NUTS, bro. Insane...

    I blew Intercooler couplers off 7-8 times today because of how much boost I am running. Those IC pipes, couplers, and hose clamps need some work. Think I got it though now. Started double clamping them lol. Ca;; me when you get a chance.
    avatar

    Post on Fri Jul 20, 2012 1:01 am by AJracer33a

    UPDATE: Alright, 14B is on, runs good. Found the reason the knock sensor was pulling timing. The plug on the knock sensor (KS) side broke. So I cut off both plugs, then wired them up directly.







    Still only boosted at 5psi. Then I made a kink in the vacuum line that goes to the J-Pipe and WG. Kinked it, zip tied it so that it stayed kinked. This will increase the pressure and the WG will never open. Basically, it is like maxing out a MBC. You can run as much boost as you can.

    NOTE: DO NOT TRY THIS. ONLY REASON I DID WAS TO CHECK TO MAKE SURE THE TURBO WAS GOOD. THEN IT BECAME ADDICTING. YOU CAN BLOW YOUR HEAD GASKET EASILY. MY ENGINE IS REBUILT SO IT IS VERY STRONG.

    I hit fuel cut very easily and can only go 1/4 throttle. But she pulls extremely hard. I spin them all the way through second and partially through third.With 1/4 throttle lol.

    Made a BLT today. Did a BLT and found a coupler was sliced open. Replaced that and started blowing IC pipes off. Since there was one less big ass leak eliminated.

    Tomorrow I will take some pics. It is kind of jimmy-rigged up. Had Monro Muffler make me a pipe to connect my J-Pipe to my IC pipe. Barely fits. I will clean her up in the morning and snap some pics.

    Going to Skyview Drags again as long as it doesn't rain. Should easily be in the 9's. Probably mid 9's.
    avatar

    Post on Sat Jul 21, 2012 7:35 pm by 93blackeclipse

    Nice! Glad you got the knock sensor fixed. cant wait to see some times again. Are you going to run it with the zip tie?
    avatar

    Post on Sat Jul 21, 2012 10:22 pm by AJracer33a

    Yep, unless I get a MBC before then. Otherwise, I gotta be careful with my throttle and watch the boost gauge. So easy to hit fuel cut.

    Kinda sucks I can't floor it but I will be able to once I get a MBC. Then set the boost for 16psi or so.

    It will obviously be quicker than my 10.3 I ran with a blown T-25 with 5psi lol.
    avatar

    Post on Sun Jul 22, 2012 8:54 pm by 93blackeclipse

    Yah, well i hope you get a mbc soon. haha Ya hopefully quicker with a better turbo. Whats next besides the mbc?
    avatar

    Post on Sun Jul 22, 2012 11:11 pm by 92tsifwd

    Cant wait to see the progress you been making man! Its gonna be a fun time wen you come down and we get this tranny in.
    avatar

    Post on Mon Jul 23, 2012 4:32 pm by AJracer33a

    93blackeclipse wrote:Yah, well i hope you get a mbc soon. haha Ya hopefully quicker with a better turbo. Whats next besides the mbc?

    Once I get a MBC and can control the boost, I think I will be quite content with the ol' daily driven DSM.

    I would like to get another set of IC piping and a FMIC. But, funds aren't quite available.

    I will just continue focusing on maintenance and reliability.

    A few months from now, I would like to get bigger injectors. But then I will need to use an AFPR and SAF-C.
    avatar

    Post on Mon Jul 23, 2012 10:57 pm by 93blackeclipse

    Oicic. Well i hope it goes good for a while now.
    avatar

    Post on Tue Jul 24, 2012 12:36 am by 92tsifwd

    If you want I may be willing to trade FMIC's with you. Mines a monster as you have seen. But Im not sure yet, I like em big lol.
    avatar

    Post on Tue Jul 24, 2012 4:54 pm by AJracer33a

    92tsifwd wrote:If you want I may be willing to trade FMIC's with you. Mines a monster as you have seen. But Im not sure yet, I like em big lol.

    I would need to get piping.
    avatar

    Post on Wed Jul 25, 2012 3:27 am by 92tsifwd

    you would need 3 inch piping lol. Its a monster!
    avatar

    Post on Wed Jul 25, 2012 8:31 am by AJracer33a

    Yea would be sickk.
    avatar

    Post on Wed Jul 25, 2012 3:06 pm by 92tsifwd

    I know I cant wait to get it hooked up!
    avatar

    Post on Wed Jul 25, 2012 11:09 pm by 93blackeclipse

    That would look great under your hood AJ!

    Post  by Sponsored content


      Current date/time is Fri Aug 18, 2017 5:59 pm